• Sprache:

Quick Info: VMware Workstation Netzwerk funktioniert nicht

Ich habe kürzlich meine VMware Workstation auf eine neue Hostmaschine umgezogen und seitdem funktionierten weder die vmnet Interfaces noch sonst irgendein Netzwerk Service von VMware. Mittels vmware-network –status lässt sich der aktuelle Zustand der virtuellen NICs und der Netservices überprüfen. Bei mir kam

Bridge networking on vmnet0 is not running
DHCP service on vmnet1 is not running
Hostonly virtual adapter on vmnet1 is disabled
DHCP service on vmnet8 is not running
NAT service on vmnet8 is not running
Hostonly virtual adapter on vmnet8 is disabled
Some/All of the configured services are not running

was ich versuchte mit vmware-network –start zu beheben. Leider bekam ich Failed to start some/all services als Antwort und musste auf Fehlersuche gehen. Des Rätsels Lösung war ein nicht aktivierter Kernelmod namens vmnet. Ein schnelles modprobe vmnet und erneutes starten des Services löste das Problem.

Quick Info: Debian hängt im Bootprozess dank IPv6

Ich habe vor kurzem einige HDDs gekauft, um mein selbst gebautes OpenMediaVault Debian NAS zu vollenden. Ich persönlich bin der Ansicht, dass IPv6 unter allen Umständen supported werden sollte, also aktivierte ich es nach Abschluss der Installation und anschließend lief alles Fehlerfrei. Über Nacht habe ich das NAS runter gefahren, da es noch keinen Inhalt hatte der dauerhaft verfügbar sein musste.
Beim nächsten Boot blieb Debian dann an einem Punkt hängen und weigerte sich weiter zu machen. Auf den ersten Blick sah es nach einem Fehler in der resolv.conf aus, da während des Boots einige Fehlermeldungen dazu kamen aber am Ende stellte sich raus, dass der NIC auf eine IPv6 Adresse vom DHCP Server auf meiner FritzBox (bitte keine Kommentare dazu, wenn ich darüber entscheiden könnte, dann wäre das Teil schon lange im Müll). In der DHCP Config war allerdings irgendetwas verstellt weshalb Debian endlos auf eine Adresse wartete.
Die Lösung für das Problem war IA_PD und IA_NA via FritzBox GUI zu aktivieren und voilà: der Boot lief fehlerfrei durch.